Hummingbird Instances not loading for some properties
Incident Report for Tenant Service Status
Resolved
The incident has been resolved. Hummingbird is operational for everyone. Thank you for the patience.
Posted May 05, 2023 - 11:54 PDT
Investigating
Our team is working on the issue. We will provide an update very soon.
Posted May 05, 2023 - 09:42 PDT
This incident affected: Hummingbird.