Intermittent Service Disruptions

Incident Report for Tenant Service Status

Resolved

The intermittent disruptions affecting Payments and other operational services have been resolved. Our Engineering team has restored the affected services and verified that they are now operating as expected.
We appreciate your patience while we worked to resolve this issue.
Posted Jul 01, 2026 - 09:29 PDT

Investigating

We are aware of an issue that may be causing intermittent disruptions to Payments and other operational services for a subset of customers. Not all customers are affected.

Our engineering team is actively investigating the issue and working to restore normal service as quickly as possible. We will continue to provide updates here as more information becomes available.

Thank you for your patience.
Posted Jun 27, 2026 - 15:13 PDT
This incident affected: Hummingbird.