New Features Live Now!
Incident Report for Tenant Service Status
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 09:16 PST
Monitoring
We're excited to unveil our latest feature upgrades that promise to enhance your platform experience. Thanks to your input and our team's commitment to innovation, we've made significant improvements that will make managing your business even smoother.

Here's a quick look at everything we've added.

What’s New:
Rent Management 2.0: Streamlined rent tracking and improved automation.
ACH Payments for Mariposa: New Secure and quick transactions now possible.
Major UI Update to Communication Center: A redesigned, more intuitive user experience.
Update to Lead Management: Better tracking for improved prospect conversion.
Management History Report: Comprehensive oversight of a property’s financial metrics over the course of a year
Cosmetic Update to Hummingbird

For a deep dive into these features, refer to this link for more details : https://www.tenantinc.com/blog/november-2023-new-feature-release-notes
Posted Nov 07, 2023 - 09:03 PST
Investigating
We're excited to unveil our latest feature upgrades that promise to enhance your platform experience. Thanks to your input and our team's commitment to innovation, we've made significant improvements that will make managing your business even smoother.

Here's a quick look at everything we've added.

What’s New:
Rent Management 2.0: Streamlined rent tracking and improved automation.
ACH Payments for Mariposa: New Secure and quick transactions now possible.
Major UI Update to Communication Center: A redesigned, more intuitive user experience.
Update to Lead Management: Better tracking for improved prospect conversion.
Management History Report: Comprehensive oversight of a property’s financial metrics over the course of a year
Cosmetic Update to Hummingbird

For a deep dive into these features, refer to this link for more details : https://www.tenantinc.com/blog/november-2023-new-feature-release-notes
Posted Nov 07, 2023 - 09:02 PST
This incident affected: Mariposa and Hummingbird.