Urgent: Action Required for A2P-10DLC Compliance by August 31st, 2023
Incident Report for Tenant Service Status
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 12:19 PDT
Monitoring
Hello,

We trust this message finds you well. We are writing to inform you about an important compliance update that requires immediate attention to ensure uninterrupted communication with your customers.

As of August 31st, 2023, all businesses are required to have an approved A2P-10DLC registration for each property in order to continue sending and receiving text messages through our platform. Failure to complete this registration by the specified deadline will result in a suspension of text messaging services for your properties "Hummingbird" and "Mariposa."

To comply with this requirement, please take the following steps without delay:

Click the link to Register: Access the registration portal by clicking on the provided link. Complete the necessary business information for each property listed.
Link: https://forms.gle/vBVHC9uQw4xxvL9PA

Timely Submission: Please note that the approval process may take several days. Thus, we strongly advise you to submit your registration at your earliest convenience to allow for ample processing time.

Attention to Detail: Accurate and complete information is essential for a successful registration. Review all details carefully before submission to avoid potential rejections.

Contact for Assistance: Should you have any questions, concerns, or need to verify your registration status, our Customer Success Management team is ready to assist. Feel free to reach out to them at CustomerSuccessManagement@tenantinc.com.

We understand the importance of maintaining seamless communication with your customers and want to ensure that your messaging capabilities are not interrupted. Act promptly to secure your A2P-10DLC compliance and continue benefiting from our text messaging services.

Thank you for your immediate attention to this matter. We appreciate your cooperation and look forward to continued collaboration.

Best regards,
Team Tenant
Posted Aug 18, 2023 - 10:00 PDT
This incident affected: Mariposa and Hummingbird.