Hummingbird Services not loading for some properties
Incident Report for Tenant Service Status
Resolved
We have put in required fixes and the systems are now operational for about last four hours. We will continue to monitor the system.
Posted Jul 28, 2023 - 16:39 PDT
Identified
Our team is working on the issue. We will provide an update very soon.
Posted Jul 28, 2023 - 11:35 PDT
This incident affected: Mariposa and Hummingbird.