Signed Documents Outage: Pandadoc API is down.
Incident Report for Tenant Service Status
Resolved
This incident has been resolved.
Posted Apr 08, 2023 - 07:01 PDT
Update
We are continuing to investigate this issue.
Posted Apr 07, 2023 - 14:49 PDT
Investigating
We are actively investigating the outage of the signed documents API. Please check back here for updates, and we appreciate your patience while we get this resolved.
Posted Apr 07, 2023 - 14:49 PDT
This incident affected: Hummingbird.