Google My Business (GMB) Account Issues
Incident Report for Tenant Service Status
Resolved
The majority of Google Business Profiles that were suspended yesterday are no longer suspended and have returned to good standing.

We will be personally reaching out to any accounts still affected to troubleshoot the issue until it is resolved.

If you have any questions, don't hesitate to contact support@tenantinc.com
Posted Nov 11, 2022 - 09:21 PST
Investigating
We're actively investigating an issue impacting multiple Google My Business listings resulting in temporary listing suspensions.

Our team is actively investigating the reason for the suspension and working with Google to restore all listings to good standing. At this time, our research points to a Google update as the cause of the suspension.

Please check back often for additional updates as we continue to investigate this issue.
Posted Nov 10, 2022 - 16:14 PST
This incident affected: Mariposa.